Mail server updates
Incident Report for GearHost
Resolved
All mail servers are now up to date. We appreciate your patience!
Posted over 1 year ago. Feb 11, 2018 - 02:35 MST
Monitoring
We will proceed with updating all mail servers. The expected downtime is expected to take anywhere from 3 - 15 minutes.
Posted over 1 year ago. Feb 11, 2018 - 01:16 MST