Mail Server Updates
Incident Report for GearHost
Resolved
All mail servers are now up to date. We appreciate your patience!
Posted about 1 year ago. Feb 28, 2018 - 21:21 MST
Monitoring
We will begin updating mail1, mail3, and mail4 to the latest version of SmarterMail. The expected downtime per server can take anywhere from 5 - 10 minutes. We appreciate your patience during this time.
Posted about 1 year ago. Feb 28, 2018 - 20:58 MST