Mail Server Updates
Incident Report for GearHost
Resolved
Mail3 and Mail4 are up to date, we appreciate your patience!
Posted over 1 year ago. Mar 06, 2018 - 03:08 MST
Monitoring
We will begin with updating mail3 and mail4 to the latest version. The expected downtime is 3 - 10 minutes.
Posted over 1 year ago. Mar 06, 2018 - 02:54 MST