Mail4 Server Updates
Incident Report for GearHost
Resolved
This has been resolved.
Posted about 1 year ago. Apr 19, 2018 - 20:11 MDT
Monitoring
We will be performing a quick update on mail4, expected downtime is 5 minutes.
Posted about 1 year ago. Apr 19, 2018 - 19:43 MDT