Mail2 Outage

Incident Report for GearHost

Resolved

This issue was a result of a network configuration issue and has been restored. We apologize for the greatly issue.
Posted Mar 01, 2020 - 17:07 MST

Identified

We are working on an issue with Mail2. We apologize and should have this back online shortly.
Posted Mar 01, 2020 - 15:59 MST
This incident affected: Email.