Mail2 Maintenance
Incident Report for GearHost
Resolved
The mail server is up to date, we appreciate your patience!
Posted about 1 year ago. Feb 26, 2018 - 20:29 MST
Monitoring
We will be performing updates on mail2 server. The expected downtime can take anywhere from 10 - 15 minutes.
Posted about 1 year ago. Feb 26, 2018 - 20:17 MST