Mail1 Maintenance
Incident Report for GearHost
Resolved
mail1 service has been restored. Thank you for your patience.
Posted 4 months ago. Feb 01, 2018 - 23:38 UTC
Monitoring
We're making some configuration changes immediately to our mail1 server due to a minor outage.
Posted 4 months ago. Feb 01, 2018 - 20:31 UTC