Mail Server Updates
Incident Report for GearHost
Resolved
All mail servers have been updated and tests were successful. We apologize for the minor inconvenience, but your email is now fully operational!
Posted 17 days ago. Nov 28, 2017 - 02:47 UTC
Monitoring
We will be performing mail server updates in the next 5 - 10 minutes. This is a hotfix patch to resolve the spool and authentication bug that many users have reported today.
Posted 17 days ago. Nov 28, 2017 - 02:15 UTC