Mail Server Updates
Incident Report for GearHost
Resolved
Servers have been fully updated and services have been restored. We truly appreciate your patience!
Posted Oct 14, 2017 - 01:46 MDT
Monitoring
We will be making some updates to a few of our mail servers, downtime is expected to take 5-15 minutes.
Posted Oct 14, 2017 - 01:32 MDT