Mail4 Server Update
Incident Report for GearHost
Resolved
The update was successful and we haven't experienced any issues for the past hour. We'll be marking this as resolved, we appreciate your patience!
Posted 7 months ago. Jan 03, 2018 - 09:53 UTC
Monitoring
We will be performing updates on our mail4 server. The expected downtime is expected to take 5 minutes.
Posted 7 months ago. Jan 03, 2018 - 08:27 UTC