Mail server maintenace
Incident Report for GearHost
Resolved
We've been monitoring mail3 for a while now, and it's operating normally. We're going to mark this as resolved.
Posted 9 days ago. Dec 06, 2017 - 04:39 UTC
Monitoring
Mail3 is currently undergoing some updates, it should be back up in a couple of minutes.
Posted 9 days ago. Dec 06, 2017 - 04:01 UTC