Mail Server Updates
Incident Report for GearHost
Resolved
The maintenance has been completed, we appreciate your patience.
Posted 15 days ago. Nov 30, 2017 - 05:39 UTC
Monitoring
We're currently performing updates across our mail environment.
Posted 15 days ago. Nov 30, 2017 - 05:24 UTC