Mail server updates
Incident Report for GearHost
Resolved
All updates have been completed.
Posted 14 days ago. Dec 01, 2017 - 04:12 UTC
Monitoring
Due to a bug on the most up to date version, we're proceeding with another emergency patch. The downtime is expected to take 5 - 10 minutes.
Posted 14 days ago. Dec 01, 2017 - 02:52 UTC