Mail Server Updates
Incident Report for GearHost
Resolved
Mail servers are up to date. We truly appreciate your patience!
Posted 10 days ago. Dec 05, 2017 - 05:52 UTC
Monitoring
We will be performing updates on some of our mail servers. The affected servers are:
mail1, mail2, and mail4. The expected downtime is 5 - 10 minutes.
Posted 10 days ago. Dec 05, 2017 - 05:42 UTC